Funnel

CRM Telephony outage
Resolved·Full outage

Our telephony services have fully recovered after our vendor resolved the underlying issue. For more details, visit https://status.twilio.com/incidents/5mbfvb8mzhcn

Tue, Apr 1, 2025, 06:52 PM
(1 month ago)
·
Affected components
Updates

Resolved

Our telephony services have fully recovered after our vendor resolved the underlying issue. For more details, visit https://status.twilio.com/incidents/5mbfvb8mzhcn

Tue, Apr 1, 2025, 06:52 PM

Monitoring

Twilio has resolved the issue, and its components are now operating normally. We have confirmed that calls are successful and we will continue monitoring to ensure telephony services remain operational. For more details on this incident, visit https://status.twilio.com/incidents/5mbfvb8mzhcn

Mon, Mar 31, 2025, 06:52 PM(23 hours earlier)

Identified

The team is continuing to monitor the Twilio incident. Here is the latest status update: Twilio has Identified the issue and is scaling up systems and deployed new hosts in order to ease customer issues. Customers may still see issues with Flex and Programmable Voice.

Mon, Mar 31, 2025, 05:00 PM(1 hour earlier)

Identified

The team has identified the issue, there is a disruption with our provider, Twilio. We are continuing to monitor and will provide updates as we learn more. Twilio's incident page: https://status.twilio.com/incidents/5mbfvb8mzhcn

Mon, Mar 31, 2025, 04:54 PM

Investigating

We are currently experiencing an outage impacting our telephony services. Our team is actively investigating the issue and will provide updates as soon as more information becomes available.

Mon, Mar 31, 2025, 04:30 PM(23 minutes earlier)
Powered by