Resolved
This incident has been resolved.
Investigating
We have identified the issue and deployed a fix. Overall system performance has completely recovered.
Investigating
We are beginning to see recovery in the CRM and are investigating. We will continue to provide updates.
Investigating
Currently, Funnel Leasing CRM is experiencing an outage. The team is investigating and will update shortly.